SonarWiz Bathymetry Processing Workflow

Revision 1.0, 12/11/2014

Chesapeake Technology, Inc.

eMail: support@chesapeaketech.com
Main Web site: http://www.chesapeaketech.com
Support Web site: http://www.chestech-support.com

1605 W. El Camino Real, Suite 100
Mountain View, CA 94040

Tel: 650-967-2045
Fax: 650-450-9300
# Table of Contents

1  SonarWiz Bathymetry Processing Workflow ........................................................................................................ 3

1.1 Bathymetric Processing Workflow (Summary) ........................................................................................................ 3

2  Workflow Steps in Post-Processing .......................................................................................................................... 3

2.1 Step 1: Create a new project .................................................................................................................................... 3

2.2 Step 2: Configuring the Survey Vessel ..................................................................................................................... 4

2.3 Step 3: Importing Data ............................................................................................................................................. 18

2.3.1 Importing the Bathymetry Data .......................................................................................................................... 18

2.3.2 Importing Auxiliary Data (Sound Velocity and Tides) ......................................................................................... 21

2.3.2.1 Importing a Sound Velocity Profile .................................................................................................................. 21

2.3.2.2 Importing Tide Data ....................................................................................................................................... 28

2.4 Step 4: Merge .......................................................................................................................................................... 31

2.5 Step 5 Navigation and Attitude Filtering .................................................................................................................. 41

2.5.1 Using the Navigation and Attitude Editor ........................................................................................................ 42

2.5.2 Using the Swath Bathymetry Editor .................................................................................................................... 43

2.6 Step 6 Bathymetry Filtering ..................................................................................................................................... 45

2.7 Step 7 Gridding ........................................................................................................................................................ 48

2.8 Step 8: Patch Test Process ................................................................................................................................... 52

2.9 Step 9 Manual filtering with the Area Editor ......................................................................................................... 59

2.10 Step 10 Exploring Bathymetric Data ...................................................................................................................... 64

2.11 Step 11 Exporting Bathymetric Data .................................................................................................................... 67
1 SonarWiz Bathymetry Processing Workflow

This document describes the 5.08 series SonarWiz bathymetry post-processing workflow. In the 5.08 series, vessel editing is all-important, and should precede file import. You set up the vessel sensors and offsets definition first, because this is important to post-processing the bathymetry data in the sonar files. We recommend the workflow sequence below, for optimal results.

1.1 Bathymetric Processing Workflow (Summary)

1. Create a new Project
2. Create/Import a new Vessel
3. Load Data Files
   a. Sonar Data
   b. Sound Velocity Casts
   c. Tides
   d. Auxiliary Navigation
4. Merge Bathymetry
5. Inspect and Filter Navigation
6. Filter the Bathymetry
7. Grid the Bathymetry
8. (Optionally) Perform Sensor Calibration (Patch Test)
9. Manually Edit Bathymetry (Swath and Area Editors)
10. Visualize Data
11. Export Data

2 Workflow Steps in Post-Processing

2.1 Step 1: Create a new project

Open the Create New Project Dialog and specify

(1) a Project Name and
(2) a Project directory. You will also need to specify
(3) an approximate location for your project and select
(4) a coordinate system.
Tip: SonarWiz can sniff the approximate project position directly from a sonar file by clicking the Get From File… button and reading one of your unprocessed data sets.

2.2 Step 2: Configuring the Survey Vessel

You must configure a vessel with information about your sonar system installation before bathymetric processing can proceed. The Vessel Editor is used to identify to SonarWiz the types of navigation, motion measurement and sonar equipment deployed on the vessel and their respective positions and orientations on the vessel. Collectively, these measurements are known as Lever Arms. All lever arms are measured relative to an arbitrary point on the vessel known as the Vessel Reference Point (VRP).

The first task on configuring a new vessel is to open the Vessel Editor and create a New Vessel:

Click the Data Acquisition Tab > Vessel > Open Vessel Editor…
Figure 2- Open the Vessel Editor Tool

This will open the Vessel Editor with a Default Vessel:
Figure 3- Vessel Editor loaded with a default vessel

Type a new name and a description for the vessel in the **Vessel Name** and **Vessel Description** text boxes. You should see that the name of the vessel changes from Default to your selected vessel name as shown in Figure 4.
Next, define the dimensions of your vessel: its (1) width, (2,3) length and (4) draft. These settings do not affect the survey data, they are used for the 3D window display.
Next specify the location of the VRP on the boat. Again, this does not affect the survey results so the location can be approximate if not known precisely.
Finally, specify the position of the **Waterline**. Both the VRP and the Waterline measurement are relative to the top of the gunwale in the diagram. Note that it is important that the vertical distance from the VRP to the waterline be accurate as this value is used in both tide computations and sonar ray tracing to determine the depth of the transducer below the water level.
Figure 6- Set the waterline relative to the VRP

At this point you should have completely defined the coordinate system of your vessel. Look at the 3D view and note that the position of the VRP is approximately correct and that the waterline is located accurately relative to the VRP.
Figure 7- 3D view of the vessel coordinate system

The 3D panel shows the vessel axis relative the VRP. All of the measurements that follow are relative to the VRP with the X, Y and Z axis positive in the direction shown by the green arrows. See also Table 1 below.

Table 1- SonarWiz lever arm axes and orientation conventions

<table>
<thead>
<tr>
<th>AXIS NAME</th>
<th>DESCRIPTION</th>
<th>SIGN CONVENTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>X - axis</td>
<td>Athwart ships</td>
<td>Positive to Starboard</td>
</tr>
<tr>
<td>Y - axis</td>
<td>Fore and Aft</td>
<td>Positive forward</td>
</tr>
<tr>
<td>Z - axis</td>
<td>Up and Down</td>
<td>Positive down</td>
</tr>
<tr>
<td>Roll</td>
<td>Rotation about the Y – axis</td>
<td>Positive starboard down</td>
</tr>
<tr>
<td>Pitch</td>
<td>Rotation about the X – axis</td>
<td>Positive bow up</td>
</tr>
<tr>
<td>Heading (Yaw)</td>
<td>Rotation about the Z - axis</td>
<td>Positive bow to starboard</td>
</tr>
</tbody>
</table>

To configure a vessel for Bathymetry processing, we will need to add 3 instruments to the vessel: (1) a SwathBathy sonar, (2) a position sensor, and (3) a motion sensor.

To add a sensor click the button labelled Add new sensor… in the lower-left corner of the vessel editor.
This opens the add sensor dialog:

Figure 9 - Adding a new sensor to the vessel

Figure 9 shows adding an Applanix POS MV position sensor to the vessel. Its sensor class is (1) Position and its Sensor model is Applanix POS MV. You can give this
sensor any Name you like to help you remember the device and you can change the color of its location marker on the 3D display. Finally, you specify the sensor location relative to the VRP on the boat. X, Y, and Z coordinates specify the translation of the sensor from the VRP. Roll, Pitch and Heading specify an orientation to apply to the sensor data (if any).

In the example (Figure 9), the position sensor is located at the VRP and there are no orientation angles to apply, so, all of the lever arms are set to zero. Click OK when you are satisfied.

You should now see the location of the Position sensor labeled on the 3D diagram with a colored dot corresponding to your selection:

![Figure 10- Position sensor located on the 3D display](image.png)

If you have made an error, you can select the sensor in the table and then click the **Edit sensor** or **Delete sensor** buttons to change the sensor.

The position sensor is important because it is the tracking point of the vessel. The X and Y coordinates of the boat will be relative to this point, as well as the Z-value if position height is used for vertical datum.

Repeat the procedure to add the motion sensor:
In this example, the motion sensor is the Applanix POS MV which, as before, is located at the VRP. So, there are zero lever arms. Click OK to add the sensor. You should see the motion sensor added to the table below the 3D display:

```
<table>
<thead>
<tr>
<th>Channel</th>
<th>Name</th>
<th>Description</th>
<th>Class</th>
<th>Towed by</th>
<th>Priority</th>
<th>XYZ offsets from RP (m)</th>
<th>Roll/pitch/heading offsets</th>
<th>Latency</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Posn</td>
<td>Position</td>
<td>Posn</td>
<td>&lt;none&gt;</td>
<td>1</td>
<td>0.000, 0.000, 0.000</td>
<td>0.000°, 0.000°, 0.000°</td>
<td>0.000</td>
</tr>
<tr>
<td>0</td>
<td>MRLU</td>
<td>Motion Sensor</td>
<td>&lt;none&gt;</td>
<td>&lt;none&gt;</td>
<td>1</td>
<td>0.000, 0.000, 0.000</td>
<td>0.000°, 0.000°, 0.000°</td>
<td>0.000</td>
</tr>
</tbody>
</table>
```

**Figure 12- Motion sensor added to the vessel**

Now add the Swath Bathy sensor:

For this example, we are using an EdgeTech 6205 interferometer:
There are a couple of things to note when configuring this sonar system. First, note that this is a two-transducer system, so SonarWiz configures 2 channels of data, channel 0 corresponds to the port-facing transducer, and channel 1 corresponds to the starboard-facing transducer. Second, the lever arms from the VRP to the transducer assembly are the same for each channel, however, channel 0 must be rotated 180-degrees to face off to the port.

The roll, pitch and heading orientation angles entered here (at this point) are usually the nominal manufacturers values (converted to SonarWiz conventions). If a patch test calibration has been completed, then adjust the nominal values accordingly. Otherwise, the calibration procedure can be done in SonarWiz. The nominal installation orientation angles for all supported sonar systems are available from CTI. A few common configurations are located in the Appendix to this walk through.

Once you click OK and return to the vessel editor, you should see the sonar marker added to the 3D display as well as a row added for each channel in the sensor table:
Figure 14- Vessel configuration after adding EdgeTech 6205

Take a moment to ensure that the Sonar is properly configured. The sonar should be properly positioned on the boat, the sonar should be below the waterline, and the individual sonar fans should be directed appropriately.

At this point, the vessel is properly configured for processing bathymetry. Close the vessel editor. Your changes are saved automatically.

Verify that the new vessel has been selected for the current project by selecting the Data Acquisition Tab > Select Vessel for Project
The Select Vessel dialog opens and you should see the survey vessel shown in the drop down:

TIP: Note the options to export and import vessels here. It is easy to import a vessel from a previous project. Save time in the future by selecting a previously used vessel from the drop down or importing a vessel from another project.

NOTE: The Export Vessel dialog saves the vessel in a hidden data directory in your Windows User account. To quickly find the xml file open Windows Explorer and paste the path:
To open the vessel directory.

```
%AppData%\Chesapeake Technology\SonarWiz 5\Vessels
```

**Figure 17- Hidden vessel directory**

### 2.3 Step 3: Importing Data

#### 2.3.1 Importing the Bathymetry Data

Once a vessel has been configured for a Bathymetry project, the next step is to import Bathymetry datasets. Select the **Post Processing Tab > Import > Bathymetry Files...**
Figure 18- Import bathymetry files

The Open dialog appears where you can shift-click the set of files you want to import.
Note that for EdgeTech files, the navigation data is stored in projected coordinates, so check the Navigation data in XY or grid format option. If there are any File Specific options these can be selected here as well (there are none for EdgeTech data).

Click Open and SonarWiz will begin importing the files. File import translates the data into SonarWiz format but does not alter the original data in any way.
After the data have been successfully imported into SonarWiz, you should see the tracklines appear in the main window display and a list of the imported files will appear under the bathymetry branch of the Project Explorer Tree:

Figure 20 - Import acoustic files progress dialog

2.3.2 Importing Auxiliary Data (Sound Velocity and Tides)
The Sound Velocity Profile and Tide importer tools are very similar in design. Both tools are designed to read a variety of simple text formats exported by other software or you can enter the required values directly.

2.3.2.1 Importing a Sound Velocity Profile
To add a sound velocity profile to the project right click the Sound Velocity File branch in the Project Explorer and select Edit/Import Sound Velocity Files…
Figure 21 - Import a new sound velocity file

When the CTISoundVelocityEditor opens up, Select **File > Import** and select the file you wish to import.

The Import dialog will appear with a preview of the file on the left and a list of templates on the right hand pane:
There are import templates for several common file formats, or you can create a new import template. To try a pre-existing template, select the template on the right and click Import. If the template was able to read the data set you will be presented with the sound velocity profile. If the template cannot read the file, an information dialog will explain that you need to create or select a new template:

And return you to the Import preview screen.
To create a new template, select **Create New Template**. The screen changes to allow you to specify a Name and Description for the new template and the number of header rows:

![Create new template dialog](image)

---

**Figure 23 - Create new template dialog**

Click the + button to add a field to the template to read the first column (depth):
Specify the field type and the Delimiter marking the end of the column. Click OK and you should see the field highlighted in the preview panel and added to the field table:

Next add the second field for Velocity, by selecting the + button again:
This time the Field type is velocity and the Delimiter is a New Line, since there are no more columns. Click OK.
Now that both columns are highlighted, click Import to import the Sound Velocity profile. This profile will be saved under the name you gave it for future use.

The profile should now be displayed for inspection and editing. Next, enter the (1) name of the profile, (2) the latitude and longitude of the profile (in decimal degrees), (3) the UTC offset if any of the time stamp, and (4) the date and time of the cast. You can also edit any of the imported points by selecting a row of data in the table and using the +/- buttons above the table.

The date, time and location of the cast may be used during sonar processing, so these values should be approximately correct.

When the cast data is correct. Save the data to a directory on your system. Note the location of the file.

Back in SonarWiz, Right Click the Sound Velocity Branch in the Project Explorer and select Add Existing Velocity Files…
When the Open dialog appears, select the xml file you just created above.

IF the SVP is checked in the Project Explorer its location will appear on the map:

2.3.2.2 Importing Tide Data
The process for importing tide files is nearly identical. First open the Tide Importer by right-clicking on the Tide branch of the Project Explorer and select **Edit/Import Tide Files**.

When the CTITideEditor opens, select **File > Import** to open the Import Template screen:
Set up a template to import the tide file or select a pre-existing template:

Click **Import** to import the file:
Give the tide file a name, description, location and time offset (if required). Save the file and note the location.

Back in SonarWiz, right-click the Tide branch in the Project Explorer and select **Add Existing Tide Files(s)**… open the tide file you just created above. Your tide file should now be added to the Project Explorer:
2.4 Step 4: Merge
Merging is the process of converting the raw angles and ranges of the sonar into georeferenced bathymetric soundings. During the merge, the raw data is read, combined with the auxiliary tides and sound velocity profiles, adjusted by the lever arms in the Vessel configuration and ray-traced to the seafloor.

All sonar data must be merged before it can be inspected, edited or processed in SonarWiz.

There are many settings that control the Merge process in SonarWiz. The default settings for the project are stored on the Bathymetry tab > Settings dialog:
These settings will be applied to all datasets unless they are overridden at the file level.
Usually you will leave attitude roll, pitch and heading set to YES, Apply heave set to YES and optionally tides, RTK heights, or Pressure depths as required.
Scrolling down the dialog you will need to set the source of surface sound velocity (Off, sensor, profile, fixed) and how ray-tracing to the seafloor will be done (Profile, Sensor Value, Mean Value, Fixed Value).

If at all possible, the user should use the surface sound velocity provided by the sound velocity sensor installed on or near the sonar (Sensor). This will correct takeoff angles for changes in the speed of sound of the water column as required. Barring that, you can pick a surface sound velocity from the sound velocity profile or enter a fixed value. If you turn the surface sound velocity option to Off, take off angles will not be adjusted for the speed of sound (not recommended).

Ray tracing to the seafloor should usually be done through a Sound Velocity Profile. However, there are situations where using a fixed speed of sound is desirable. Full profile tracing is turned on with the Profile option, the other options all use a fixed value. The source of the fixed velocity values can be derived from the surface speed of sound sensor (sensor), the mean of the sound velocity profile (Mean Value), or a user-entered value (Fixed value).
When an option like Tide correction or SVP Profile are selected, the user will need to also specify the specific file or files that are to be applied. Click the (…) icon to the right of the file box to open a file dialog to fill in the path name required.

The Downsampling filter applies a statistical mean or median filter to the raw data to replace a group of neighboring samples with an aggregate value. You can specify the horizontal width of the bin and the type of down sampling filter to apply. For each ping, the median filter sorts all the samples in a given horizontal bin by elevation and then returns the sample with the median elevation value. The mean filter averages together the position, amplitude and elevation values of all the samples in a given bin and returns the average value. In both cases, the filters return a single sample per bin, so the horizontal bin size sets the across-track resolution.

SonarWiz can handle several hundred samples per ping efficiently, but the software begins to lag when it needs to push around thousands of samples. Often, interferometers have a large number of samples of low precision where the downsampling filter can improve the quality of the data and greatly decrease the processing time.

The remaining items in the Project Settings dialog pertain to filtering and will be discussed below.

Click OK to save the project default settings.

To MERGE a sonar file or remerge a sonar file, select the file in the Project Explorer and hit the Merge Button in the tool bar, or right-click and select merge.
The Merge file selection panel opens giving you the option to add or remove files for merging.

Click Next.
The Merge – Auxiliary Data Selection screen allows you to override the project default settings if desired. We can enter in the tide and svp files here too:
Click Next.
SonarWiz will summarize the settings you are going to apply. Double-check that everything is what you want. Click Next.
SonarWiz checks to make sure that all of the settings are compatible, that sound velocity profiles have been provided if required, that tide files are provided if required. If everything is green, you can click Finish and merge the data.

A few notes about merging:

1. All dataset must be merged before any filtering, gridding, visualization or editing can be done
2. If any underlying data is changed, such as a change to the vessel configuration, the bathymetry files will need to be re-merged to reflect the change. SonarWiz will indicate the merge status of a file by the color of the icon next to a file’s name in the Project Explorer: Green = Good Status, Yellow = pre-merge file, Red = out-of-date. Both, red and yellow files should be re-merged.
3. Merging resets your data back to the raw state. Any manual filtering or editing will be lost.
When the Merge process is completed. The merge status indicators next to each filename will turn Green, you will be able to visualize sonar data in the main window and all of the editors will be available.

2.5 Step 5 Navigation and Attitude Filtering
SonarWiz provides a number of different filtering options for navigation, attitude and bathymetry data. Most CTI editors share common controls:

The Graphics Settings button control the graphical performance of the tools, particularly when rendering 3D data, but need only be modified if your computer experiences difficulty with the default options.

Application settings often contain settings for the color, size and density of displayed lines and points. Check here to increase the size of points on a small laptop screen, or to change the size and color of trackline and map decorations.

The 3 selection options: Rectangle, Polygon and Lasso selection change the behavior of the selection tools. The rectangle selects all data in a box drawn with the mouse. The polygon allows the user to click multiple times to outline a non-rectangular area, be sure to close the polygon by clicking on the first point again, a small circle will appear when
the mouse hovers over the first point to indicate that the next click will close the polygon. The Lasso selection also allows for polygon selection, but there is no need to close the polygon.

Show rejected points (sometimes found in the Application Settings dialog) will reveal previously flagged samples so that they can be re-selected and accepted.

Once a selection has been made, click the Accept button to change the flag to accept; click reject to change the flag to reject. If show rejected is not checked, the flagged samples will not be displayed (but they are never deleted permanently).

Interpolate will allow gaps in the data to be interpolated across. The context of the selection determines the type of interpolation performed.

Undo and Redo allow you to restore the previous state of the program.

2.5.1 Using the Navigation and Attitude Editor
Launch the **Navigation and Attitude Editor** by selecting a bathymetry file in the Project Explorer and then either clicking the Navigation & Attitude Editor button in the tool bar, or right-click the bathymetry file and select **Navigation and Attitude Editor…** from the menu.

The Navigation and Attitude editor displays the sensor data on the right-hand panes and the location along the trackline on the plan view pane on the left:
Selecting a section of bad data along one of the sensor lines and hitting interpolate will delete the bad data and interpolate through the gap. Sliding the time window on the right-hand pane will slide the box on the map view to indicate your position on the line.

The Dataset list tab on the left allows you to quickly step through the datasets for inspection, while the Tabular View tab displays the raw navigation and attitude data in a grid.

TIP: It is a good idea to inspect the attitude and navigation for each track line early in the processing workflow to ensure that no unexpected equipment malfunctions have occurred.

### 2.5.2 Using the Swath Bathymetry Editor

The swath bathymetry editor allows for inspection and editing of individual tracklines. The 3-pane view shows a cross-section of the sonar profile, a top-down view of the data and a side-view of the data. Points can be selected for editing in any of the 3 views using the same tools previously described. In addition, the editor has a selection of semi-automatic filters that can filter all of the data in the display at once.
The Min & Max filter sets absolute gates for either accepting or rejecting data:

The Point Density Filter works by dividing the cross profile into a grid of bins in X and Y. If any bin fails to contain the specified minimum number of points, all of the points in the bin will be rejected. This filter is very effective at selecting and removing outliers.
The Polyline selection filter allows the user to draw a polygon around the valid data and reject all data outside the polygon.

2.6 Step 6 Bathymetry Filtering
A series of fully automatic filters are provided for filtering track line bathymetry. The default filter settings can be specified by clicking on Bathymetry Tab > Settings button and scrolling down to the first filter setting: Manufacturer Flag Filter. Alternatively, select the files you wish to filter in the Project Explorer and click the Filter icon, or simply Right-click the files and choose Filter… from the Pop up menu. In these cases, the filter options will be presented to you before the filter is run.
When Filters are executed, the filter process starts by unflagging any previously flagged data EXCEPT manually flagged data. The only way to restore manually flagged data is to manually Accept the data again or to re-merge the file (which resets all editing). This protects your work from an accidental overwrite of the filter flags.

The filters are run in series, in the sequence in which they appear in the selection dialog, and consist of the following:

1. Manufacturer Flags Filter
2. Channel Filter
3. Range Filter
4. Cutoff Angle Filter
5. Water Column Filter
6. Bathymetry Box Filter
7. Along Track Filter

If a mistake is made in automatic filtering, simply re-run the filters with the correct values and the data will be restored.

To activate a filter turn, set the filter status to YES. To turn a filter off set its status to NO.
<table>
<thead>
<tr>
<th>Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Manufacturer Flag Filter</strong></td>
<td></td>
</tr>
<tr>
<td>Enable Filter</td>
<td>Yes</td>
</tr>
<tr>
<td>Manufacturer Filter Outliers</td>
<td>No</td>
</tr>
<tr>
<td>Manufacturer Filter Water Column</td>
<td>No</td>
</tr>
<tr>
<td>Manufacturer Filter SNR</td>
<td>No</td>
</tr>
<tr>
<td>Manufacturer Filter Quality</td>
<td>Yes</td>
</tr>
<tr>
<td>Manufacturer Filter Amplitude</td>
<td>No</td>
</tr>
<tr>
<td><strong>Channel Filter</strong></td>
<td></td>
</tr>
<tr>
<td>Enable Channel Filter</td>
<td>No</td>
</tr>
<tr>
<td>Use Channel 0</td>
<td>Yes</td>
</tr>
<tr>
<td>Use Channel 1</td>
<td>Yes</td>
</tr>
<tr>
<td>Use Channel 2</td>
<td>Yes</td>
</tr>
<tr>
<td>Use Channel 3</td>
<td>Yes</td>
</tr>
<tr>
<td><strong>Amplitude Filter</strong></td>
<td></td>
</tr>
<tr>
<td>Enable Amplitude Filter</td>
<td>No</td>
</tr>
<tr>
<td>Amplitude Filter Bas</td>
<td>1.500000</td>
</tr>
<tr>
<td><strong>Range Filter</strong></td>
<td></td>
</tr>
<tr>
<td>Enable Range Filter</td>
<td>No</td>
</tr>
<tr>
<td>Filter Near Range</td>
<td>0.000000</td>
</tr>
<tr>
<td>Filter Far Range</td>
<td>200.000000</td>
</tr>
<tr>
<td><strong>Cutoff Angle Filter</strong></td>
<td></td>
</tr>
<tr>
<td>Enable Cutoff Angle Filter</td>
<td>No</td>
</tr>
<tr>
<td>Minimum Cutoff Angle</td>
<td>-70.000000</td>
</tr>
<tr>
<td>Maximum Cutoff Angle</td>
<td>70.000000</td>
</tr>
<tr>
<td><strong>Water Column Filter</strong></td>
<td></td>
</tr>
<tr>
<td>Enable Water Column Filter</td>
<td>No</td>
</tr>
<tr>
<td>Threshold Fraction</td>
<td>0.800000</td>
</tr>
<tr>
<td><strong>Bathymetry Box Filter</strong></td>
<td></td>
</tr>
<tr>
<td>Enable Bathymetry Box Filter</td>
<td>No</td>
</tr>
<tr>
<td>Filter Minimum Depth</td>
<td>No</td>
</tr>
<tr>
<td>Filter Maximum Depth</td>
<td>No</td>
</tr>
<tr>
<td>Filter Minimum Horizontal Range</td>
<td>No</td>
</tr>
<tr>
<td>Filter Maximum Horizontal Range</td>
<td>No</td>
</tr>
<tr>
<td>Minimum Depth</td>
<td>0.000000</td>
</tr>
<tr>
<td>Maximum Depth</td>
<td>200.000000</td>
</tr>
<tr>
<td>Minimum Horizontal Range</td>
<td>-500.000000</td>
</tr>
<tr>
<td>Maximum Horizontal Range</td>
<td>500.000000</td>
</tr>
<tr>
<td><strong>Along Track Filter</strong></td>
<td></td>
</tr>
<tr>
<td>Enable Bathymetry Along Track Filter</td>
<td>No</td>
</tr>
<tr>
<td>Number of Pings</td>
<td>6</td>
</tr>
<tr>
<td>Vertical Threshold</td>
<td>2.000000</td>
</tr>
<tr>
<td>Horizontal Bin Size</td>
<td>0.250000</td>
</tr>
</tbody>
</table>

**Horizontal Bin Size**
Width of the horizontal bins in map units. (default = 1.0)
The **Manufacturer’s Filter** is used to flag samples that failed one or more of the manufacturer’s quality checks. Not all sonars have the same manufacturer’s flags available.

The **Channel Filter** will turn on or off the available sonar channels. Most sonars have a single channel per transducer. For a single-transducer system such as a multibeam, channel zero is the only available channel, for multi-headed systems the channels are numbered from 0 (usually port-facing), 1 (usually starboard facing), 3 (forward-facing), etc.

The **Amplitude filter** this filter is for future use.

The **Range Filter** flags all samples with a slant range closer than Near Range or further away than Far Range.

The **Cutoff Angle Filter** flags all samples with swath angles beyond the specified Minimum and Maximum cutoff angles.

The **Water Column Filter** flags all samples above the seafloor by the given fraction. For example, a value of 0.8 would flag all sample shallower than 80% of nadir depth (< depth x 0.8).

The **Bathymetry Box Filter** sets hard depth and horizontal range limits beyond which all samples are flagged.

The **Along Track Filter** divides each ping into a series of bins. Each bin is *Horizontal Bin Size* wide by *number of pings long*. A mean depth is calculated for each bin and if a sample is above or below the mean depth by more than *threshold*, the sample is flagged. Otherwise, the sample is added to the bin and compared with future samples. If the seafloor is flat and featureless, increase the size of the bins and reduce the cutoff threshold to improve filtering, if the seafloor is very rough, reduce the size of the bins (especially the number of pings) or increase the cutoff threshold.

### 2.7 Step 7 Gridding

At any time after merging, we can create a raster of our dataset for visualization and export into other programs. To create a grid, check ON the bathymetry files you want to include in the grid. Then, right click the Grid branch in the Project explorer and select **Create New Grid**:
The new grid dialog opens where you can select

(1) the grid dimensions,

(2) the gridding method,

(3) the output name, and

(4) add to project.
Because this is unfiltered data, we will make a median grid at 1 m resolution and add it to the project explorer.

The grid is added to the project beneath the bathymetry lines (you may want to turn the bathymetry lines off to get a better look at the grid).
You can change the color ramp of the grid (and the bathymetry display) by selecting the View Tab, Bathymetry View > Depth Scale

From the depth scale you can change the color ramp and how the color ramps are mapped to the bathymetry:
You can also control the shaded relief effect of the bathymetry by selecting the **View Tab > Bathymetry Views > Shaded Relief**: 

![Shaded Relief Image Settings](image)

**2.8 Step 8: Patch Test Process**

Once the data has been imported into SonarWiz, we will use the Patch Test tool to refine the sonar installation parameters. To see the problem, select the Bathymetry Tab.
> Cross section tool and draw a cross section across the data from the northeast to the southwest (perpendicular to the track lines).

To perform a patch test, we proceed by correcting pitch, then roll, then heading. To correct for pitch we need a target on the seafloor over which the boat traversed in opposite directions. An area in this example dataset exists as shown in the image below:

To start the patch test tool, select the Bathymetry Tab > Patch Test and then draw a box over the highlighted area:

The Patch Test Calibration tool (PTC) opens showing a coarse grid of the area over the rock reef along with arrows indicating the direction of travel.
Pitch tests should compare overlapping profiles over a target with the vessel traveling in opposite directions, such as the two green track lines in green. Hold down the shift key and draw a profile right along the nadir of the two green tracklines:

You should see a 3D profile along the tracks across the rock reef. The upper panel shows the profile points.
The EdgeTech 6205 is a dual-channel system, so there will be patch test parameters for each channel. Select Calibration type: Pitch Tx 1, Set the nominal pitch angle to 0.0, and the step size to 0.5 degrees. The automatic pitch test will check each angle between -10 and +10 in 0.5-degree increments looking for the closest alignment of the elevation data in the cross-section shown above. Click the Re-calculate button to start the test:

If the test was successful, you should see (1) a clean V-Graph showing that the solution converged over the reported angle, (2) the reported angle is set in the dialog, (3) the reported angle is set as a candidate for replacing the existing pitch value, and (4) the profile should look better!

We can refine the number by decreasing the step size, re-setting the minimum and maximum bounds and running re-calculate again:
I got about the same number on the refined run (-1.0). Because pitch is often the same for both transducers mounted on the same head, I just manually copied the pitch value from Tx 1 into Tx 0 as shown:

To store these values hit the Save To Vessel button in the toolbar. Close the tool and Re-merge the data.

To run the Roll Calibration Tests, I selected a polygon region across the flats in the southern part of the data set.

Again, hold down the shift key to draw a profile, only for the roll tests, draw the profile perpendicular to the track lines as shown:
The first run on the port channel got a strong solution about -0.388 degrees. Re-running the refined test with a 0.1-degree step size resulted in a final solution of -0.4 degrees. Following the same procedures, I got a value of -0.17 degrees for the Starboard channel:

<table>
<thead>
<tr>
<th>Test</th>
<th>Channel</th>
<th>Current</th>
<th>New</th>
<th>Save</th>
</tr>
</thead>
<tbody>
<tr>
<td>Roll</td>
<td>Port (Tx 0)</td>
<td>0.000</td>
<td>-0.400</td>
<td></td>
</tr>
<tr>
<td>Roll</td>
<td>Starboard (Tx 1)</td>
<td>0.000</td>
<td>-0.017</td>
<td></td>
</tr>
<tr>
<td>Pitch</td>
<td>Port (Tx 0)</td>
<td>-1.000</td>
<td>-1.000</td>
<td></td>
</tr>
<tr>
<td>Pitch</td>
<td>Starboard (Tx 1)</td>
<td>-1.000</td>
<td>-1.000</td>
<td></td>
</tr>
<tr>
<td>Heading</td>
<td>Port (Tx 0)</td>
<td>180.000</td>
<td>180.000</td>
<td></td>
</tr>
<tr>
<td>Heading</td>
<td>Starboard (Tx 1)</td>
<td>0.000</td>
<td>0.000</td>
<td></td>
</tr>
<tr>
<td>PositionLatency</td>
<td>Port (Tx 0)</td>
<td>0.000</td>
<td>0.000</td>
<td></td>
</tr>
<tr>
<td>PositionLatency</td>
<td>Starboard (Tx 1)</td>
<td>0.000</td>
<td>0.000</td>
<td></td>
</tr>
</tbody>
</table>

Note that the Current column indicates what is currently stored in the vessel configuration. The New column indicates the new candidate value. You can check to save or not save the value or simply close the tool and no modifications will be made. We'll save the roll values.
The heading calibration test is similar to the Pitch test, only for heading, you want to compare a target between two track lines (rather than along the nadir) using the same transducer going in opposite directions:

After running both the port and starboard heading calibrations, I came up with the following final calibrated values:

<table>
<thead>
<tr>
<th>Test</th>
<th>Channel</th>
<th>Current</th>
<th>New</th>
<th>Save</th>
</tr>
</thead>
<tbody>
<tr>
<td>Roll</td>
<td>Port (Tx 0)</td>
<td>-0.521</td>
<td>-0.521</td>
<td>✓</td>
</tr>
<tr>
<td>Roll</td>
<td>Starboard (Tx 1)</td>
<td>-0.500</td>
<td>-0.500</td>
<td>✓</td>
</tr>
<tr>
<td>Pitch</td>
<td>Port (Tx 0)</td>
<td>-1.000</td>
<td>-1.000</td>
<td>✓</td>
</tr>
<tr>
<td>Pitch</td>
<td>Starboard (Tx 1)</td>
<td>-1.000</td>
<td>-1.000</td>
<td>✓</td>
</tr>
<tr>
<td>Heading</td>
<td>Port (Tx 0)</td>
<td>-181.500</td>
<td>-181.500</td>
<td>✓</td>
</tr>
<tr>
<td>Heading</td>
<td>Starboard (Tx 1)</td>
<td>-1.500</td>
<td>-1.500</td>
<td>✓</td>
</tr>
<tr>
<td>PositionLatency</td>
<td>Port (Tx 0)</td>
<td>0.000</td>
<td>0.000</td>
<td>✓</td>
</tr>
<tr>
<td>PositionLatency</td>
<td>Starboard (Tx 1)</td>
<td>0.000</td>
<td>0.000</td>
<td>✓</td>
</tr>
</tbody>
</table>

Save these values to the vessel. You can close the PTC and open up the Vessel Editor to confirm that the vessel has been updated with the new calibrated values:
2.9 Step 9 Manual filtering with the Area Editor

Be sure that bathymetry is turned on (checked) in the Project Explorer and then click the Area Editor button in the Bathymetry Toolbar. The cursor will change to a cross and you are expected to draw a rectangle or polygon over the plan view of the bathymetry.

The editor can handle about 1 million points before it bogs down, so adjust the size of your polygon appropriately. The Area Editor window will launch with a screen that looks something like this:
The point cloud of data is shown on the right, a quick grid of the data is shown on the left. The toolbar has many of the same filtering tools available for manually and semi-automatic filtering of data. The min/max filter and the point density filter return and there are two additional filters available:

**The Median Filter** allows for setting the cell size of a median filter and a threshold. If any point in the cell is above or below the median elevation by more than the threshold, that point is selected:
Here the red points have been selected after running the median filter. You can chose to reject these points or make another selection with different settings.

**The Grid Surface Filter works** in a similar way to the median filter, but you have more control over the creation of the reference surface. First, create a low-resolution grid of the data by hitting the Grid Refresh button in the tool bar:

The gridding dialog opens. Select parameters that will be relatively insensitive to outliers, a low-resolution median grid for example will not be sensitive to outliers found well above or below the surface:
The grid display on the left of the screen will update showing the low-resolution filter grid. If there are spikes or major gaps in the data click the **Edit Grid** button and open the Grid editing tab:
Here in the grid editor you can remove spikes and interpolate across gaps. The goal is to quickly create a reference surface which will be used to filter the raw point cloud. This surface won’t be saved when you are done. When the grid is ready, click accept changes.

Once back in the General Tab, select the **Grid Surface Filter** button:
You can now set the tolerance above the reference surface grid for selecting points in the raw point cloud. Reject the points that are well above or below the reference surface.

Re-create the reference surface grid at higher resolution and run through the process again. You will quickly be able to clean up very noisy data and pull out just the sea floor returns.

2.10 Step 10 Exploring Bathymetric Data

Two dimensional profiles can be drawn across bathymetry by first checking one or more bathymetry files ONm and then selecting the Bathymetry Tab > Cross section tool. Draw a line across the data and the profile will be displayed in the profile tool:
Bathymetric data can gridded (See Step 7) and loaded into the 3D viewer for visualization where it can be combined with other data such as point clouds, sub-bottom profiles and sidescan mosaics.

For example, here is the sidescan mosaic GeoTiff draped over the bathymetry to add additional information to the scene:
To drape the sidescan over the scene. First export the sidescan data as a GeoTiff image. Then in the 3D viewer:

1. Load the Grid data in the viewer (File > Load Grid…).
2. Open the GeoTiff of the sidescan in the viewer (File > Load Image…)
3. Turn on the Scene Manager (View > Scene Manager)
4. Select the Grid in the Scene Manager and set the World/image pair dropdown to the GeoTiff image:

2.11 Step 11 Exporting Bathymetric Data
Processed bathymetric data can be exported to a variety of formats.
To export one or more individual track lines:
Click the Post Processing Tab > Bathymetry Exports to see a variety of options including XYZ files, grid files, Generic Sensor Format (GSF) files, Contour Shapefiles, and Shaded Relief Imagery.

The processed grids can also be exported and convert to a wide variety of formats. Select a grid file in the Project Explorer, Right-Click and select Export Grids… to see the Export Grid Dialog:
More than 20 output raster formats are supported at this time, and more are planned.